Cloudflare Degradation Affecting Management Portal

Incident Report for VictoriaMetrics Cloud

Resolved

This incident has been resolved.
Posted Nov 18, 2025 - 18:34 UTC

Monitoring

Cloudflare implemented fix and monitoring the issue
Posted Nov 18, 2025 - 15:38 UTC

Investigating

We are currently investigating an issue with the Management Portal (console.victoriametrics.cloud) due to degraded performance reported by Cloudflare. Customer workloads are not affected. We recommend using cloud.victoriametrics.com for direct access until the issue is resolved. You can monitor the Cloudflare status here: https://www.cloudflarestatus.com/.
Posted Nov 18, 2025 - 13:16 UTC
This incident affected: Management Portal.